COMMUNITY - FORUMS - TECHNICAL SUPPORT
Major issue with store checkout
+0

I tried to purchase Founder pledge package. I got to check out, filled out the info, agreed to terms and hit Checkout. A confirmation screen pops up and I hit the Confirm button and then the screen closes and goes back to the cart with the item still in there. No Status or confirmation of a purchase and when I look at my transactions it is blank. I thought it was bugged. Cleared the cart and tried again. Same issue.

What's the deal?

>OS: Windows 10 64-bit

>Browser: Chrome Version 69.0.3497.100 (Official Build) (64-bit)


10/24/2018 7:12:55 AM #1
+0

Have you tried clearing your cache and stuff? Its suppose to bring up the xsolla payment process.

Is it possible that its being blocked?


10/29/2018 7:47:57 PM #2
+0

We're sorry to hear you are experiencing an issue. But we're not aware of any issues with our store or website at this time.

If you've cleared your cache and tried a different browser as well as any other troubleshooting steps and that still didn't resolve it, I recommend contacting Xsolla directly.

They handle 100% of the payment transaction process on our online store.

Thank you.


"Stupid questions make more sense than stupid mistakes."